Author Topic: Heroside badges not being tracked  (Read 4064 times)

dclark

  • Underling
  • *
  • Posts: 3
Heroside badges not being tracked
« on: June 02, 2009, 02:18:03 PM »
I just downloaded the latest bind files, Glycerine and HeroStats.  When I went onto my villain and used the settitle binds, all his badges were caught by TNT and added to the site.  But when I logged onto my Hero and did the same, none of the badges were being caught by TNT, or HeroStats...setting my title manually doesn't add them either.  Why is this and what can I do to get them verified?

SaintNicster

  • Elite Boss
  • *****
  • Posts: 865
Re: Heroside badges not being tracked
« Reply #1 on: June 02, 2009, 02:37:41 PM »
I just downloaded the latest bind files, Glycerine and HeroStats.  When I went onto my villain and used the settitle binds, all his badges were caught by TNT and added to the site.  But when I logged onto my Hero and did the same, none of the badges were being caught by TNT, or HeroStats...setting my title manually doesn't add them either.  Why is this and what can I do to get them verified?
*shrugs*

If HeroStats isn't reading detecting the badges, there may be a glitch with the channels.  Try looking at this blog by Skip/Ineffablebob.


dclark

  • Underling
  • *
  • Posts: 3
Re: Heroside badges not being tracked
« Reply #2 on: June 02, 2009, 02:53:01 PM »
That doesn't seem to have anything to do with settitle...just when badges are earned.  In fact, earning a badge while they are running does add them to the list.  Just settitle doesn't work all of a sudden.  Anyone else have any ideas?

Edit:  I just checked, and badges are being added when I log onto other heroes...just not my main hero.
« Last Edit: June 02, 2009, 03:31:59 PM by dclark »

SaintNicster

  • Elite Boss
  • *****
  • Posts: 865
Re: Heroside badges not being tracked
« Reply #3 on: June 02, 2009, 03:48:54 PM »
That doesn't seem to have anything to do with settitle...just when badges are earned.  In fact, earning a badge while they are running does add them to the list.  Just settitle doesn't work all of a sudden.  Anyone else have any ideas?

Edit:  I just checked, and badges are being added when I log onto other heroes...just not my main hero.

Read this blog.  It has a few troubleshooting steps.

It boils down to this.  /settitle creates a chat message in the System channel, which the HeroStats engine reads and sends to Glyc.  If HeroStats isn't reading those messages, there is an issue with the way your tabs are setup.  I know this has happened before, as HeroStats used to have an issue with my main (created in Aug04) and not being able to read his system channel unless I put the system channel in like every tab.  The i12 fix linked before completely cleared up this him.  You should still give it a try.


dclark

  • Underling
  • *
  • Posts: 3
Re: Heroside badges not being tracked
« Reply #4 on: June 02, 2009, 06:16:32 PM »
Ah, that was it.  I had taken the system channel off my main's chat tab.  Thanks :)