Author Topic: Upgrading/Reinstalling 1.959  (Read 5213 times)

LtlBtyRam

  • Minion
  • **
  • Posts: 30
Upgrading/Reinstalling 1.959
« on: July 16, 2012, 11:14:50 PM »
I've done everything I can think of to get the new version installed.  I tried upgrading by closing the old version, then uninstalling altogether, restarting my machine, then re-installing.  I still can't get Mids to open. 

I get an update pending window saying a recently downloaded update pack has not yet been applied.  In order for a previously downloaded update to be applied it must restart. The program will now exit to apply the update.  Please close any other running instances of Mids.  If this message is in error please delete MHD.mhz file in C:\Program Files (x86)\Titan Network\Mids Hero Designer directory.

I've tried clicking ok and then get an error window saying the system cannot find the file specified.

As I've said I tried completely uninstalling restarting machine and re-installing, even doing this I get these messages.

cybermitheral

  • Lieutenant
  • ***
  • Posts: 95
Re: Upgrading/Reinstalling 1.959
« Reply #1 on: July 16, 2012, 11:51:50 PM »
Just as a test can you install to a different directory/drive?

cybermitheral

  • Lieutenant
  • ***
  • Posts: 95
Re: Upgrading/Reinstalling 1.959
« Reply #2 on: July 17, 2012, 12:16:07 AM »
Well that shut me up... I had the exact same issue.

I renamed the D:\Program Files (x86)\Titan Network\Mids Hero Designer\mhd.mhz as indicated in the screen prompt and tried again but no luck.
I renamed the "Titan Network folder", renamed my "Hero & Villain Builds" folder (in Documents) and ran the install from the Internet (didnt download the file first) to my original location.
I then renamed the "Hero & Villain Builds" back and ran Mids and it worked.

I looked at both my original Mids folder and the newly installed one and the new folder does NOT have the mhd.mhz file at all.

LtlBtyRam

  • Minion
  • **
  • Posts: 30
Re: Upgrading/Reinstalling 1.959
« Reply #3 on: July 17, 2012, 01:49:40 AM »
@cybermitheral
So when you start mids does it still want to try to update?  The first time I tried to load Mids after the re-install it wanted to update.  I clicked no and it started fine on the correct version.  Now I can start Mids without the update prompt with the correct version.  Do you know if this correct in terms of the database info because that was what the update prompt was for?

Codewalker

  • Hero of the City
  • Titan Network Admin
  • Elite Boss
  • *****
  • Posts: 2,740
  • Moar Dots!
Re: Upgrading/Reinstalling 1.959
« Reply #4 on: July 17, 2012, 02:27:15 AM »
If you did accept the database update, you'll probably have to reinstall. For some reason the mids auto-updater is confused and was trying to download a really old database version.

To work around it, I've temporarily removed database updates altogether from the server, until we can figure out what's causing it. The current download package includes the most recent database, but if you downloaded that old one it may cause problems.

monkeyslap

  • Minion
  • **
  • Posts: 24
Re: Upgrading/Reinstalling 1.959
« Reply #5 on: July 17, 2012, 02:42:36 AM »
I've done everything I can think of to get the new version installed.  I tried upgrading by closing the old version, then uninstalling altogether, restarting my machine, then re-installing.  I still can't get Mids to open. 

I get an update pending window saying a recently downloaded update pack has not yet been applied.  In order for a previously downloaded update to be applied it must restart. The program will now exit to apply the update.  Please close any other running instances of Mids.  If this message is in error please delete MHD.mhz file in C:\Program Files (x86)\Titan Network\Mids Hero Designer directory.

I've tried clicking ok and then get an error window saying the system cannot find the file specified.

As I've said I tried completely uninstalling restarting machine and re-installing, even doing this I get these messages.

I too had the exact same problem. I'm using Windows 7 64bit. For some strange reason I am not seeing Mids' in the Windows 7 Programs&Features list, nor have ever seen it there when installing new versions, so I had to go into Program Files (x86) and use the Mid's manual uninstaller. I didn't delete the Titan Network folder and just installed the new Mids'. That's when I received the same errors you had. So I uninstalled Mids' again but this time deleted the whole Titan Network folder in Program Files (x86). Reinstalled it and it seems to work fine now.

There was 1 typo though. After installing it and launching it for the first time, I had the pop up about whether or not I wanted automatic updates on and the typo read "Welcome to Mids' Hero Designer 1.96!". The first pop up after it is installed that has the check box to run Mids', as well as the about in Mids' showed correctly the version as 1.959.

After installing it:


Text error when launching it for first time:

cybermitheral

  • Lieutenant
  • ***
  • Posts: 95
Re: Upgrading/Reinstalling 1.959
« Reply #6 on: July 17, 2012, 04:14:12 AM »
How DARE Mids round up to two decimal places :)

Im running build 1.959 now on my work pc. It does have some issues however with the Bio armor toggles not appearing at all on Brutes/Tanks and overlapping on Staff Melee Scrappers.

Already made a post about this in the 1.959 thread.

Diellan

  • Titan Staff
  • Elite Boss
  • ****
  • Posts: 540
    • SG/VG Site
Re: Upgrading/Reinstalling 1.959
« Reply #7 on: July 17, 2012, 04:53:02 AM »
There was a bug with the auto-updater notification on the server that caused it to ask people to download an old version of the database. Codewalker disabled that, so it shouldn't happen again, but those of you who did so will need to reinstall the new Mids version (and maybe delete any extraneous mhz files in the Mids folder). Sorry about that.

LtlBtyRam

  • Minion
  • **
  • Posts: 30
Re: Upgrading/Reinstalling 1.959
« Reply #8 on: July 17, 2012, 06:37:16 PM »
Like I stated to cybermitheral I declined the auto update option after doing a complete re-install and it seems to have fixed the strangeness.  I appreciate all of the help especially from the devs.  This community is just awesome!!!!  ;D

Cannonfodder

  • Lieutenant
  • ***
  • Posts: 84
Re: Upgrading/Reinstalling 1.959
« Reply #9 on: July 17, 2012, 07:56:02 PM »
I had the same problem yesterday and was almost through composing a forum post when I tried something first.

I deleted my Mids folder from the Titan folder, then reinstalled using the new version. 

That worked fine for me (I just had to re-customize my settings/options/view).
--Jason
@Cannonfodder
Victory:  Cannonfodder 50 Inv/SS
Virtue:  Pravda 50 Bots/FF
The Hall of Justice/The Hall of Doom /chanjoin "Victory Badges" /chanjoin "Virtue Badges"